[ocaml-platform] Make compatible ocaml, camlp4, ppx, node, js_of_ocaml, ocamlbuild
softtimur at gmail.com
Thu May 19 05:58:58 BST 2016
I have messed up my OPAM system, here is the error:
:testweb $ opam switch reinstall system
Your system compiler has been changed. Do you want to upgrade your
OPAM installation ? [Y/n] y
=-=- Upgrading system
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-= 🐫 [WARNING]
base-ocamlbuild.base is not available because it requires OCaml >=
3.10 & < 4.03. Skipping.[WARNING] camlp4.4.02+system is not available
because your system doesn't comply with preinstalled &
ocaml-version >= "4.02" & ocaml-version < "4.03".
Skipping.[WARNING] ppx_tools.4.02.3 is not available because your
system doesn't comply with ocaml-version >=
"4.02.0" & ocaml-version < "4.03.0". Skipping.
The following dependencies couldn't be met:
- deriving -> camlp4
Your request can't be satisfied:
- camlp4 is not available because your system doesn't comply with
ocaml-version >= "4.04".
No solution found, exiting
The former package state can be restored with opam switch import
The entire question is on the stackoverflow
Could anyone help?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Platform