[opam-devel] Leaving 3.12.x support behind

Anil Madhavapeddy anil at recoil.org
Sun Mar 17 15:58:58 GMT 2013

OPAM doesn't really mandate any particular version of the compiler.
It simply requests that you keep the correct 'ocaml-version' constraint
in the OPAM file so that users will not get a build error when using
an incompatible compiler.

So if you feel that you wish to move to a newer Core, then go right


On 17 Mar 2013, at 10:52, Malcolm Matalka <mmatalka at gmail.com> wrote:

> I have a situation where the interface to Async has changed between
> 108.08.00 and 109.13.00.  It is a simple change, but by making the
> change I am giving up support for Ocaml 3.12.x, as far as I can tell.
> Is this the accepted direction for opam packages?
> /Malcolm
> _______________________________________________
> opam-devel mailing list
> opam-devel at lists.ocaml.org
> http://lists.ocaml.org/listinfo/opam-devel

More information about the opam-devel mailing list