[opam-devel] opam 1.1.1 and aspcud 1.9

Louis Gesbert louis.gesbert at ocamlpro.com
Wed Dec 10 01:15:37 GMT 2014

I've been trying to reproduce the issue, but things seem fine, sort of:

>From what I could gather:
* trusty (14.04LTS) has 1.1 and aspcud 1.8, it works fine
* utopic (14.10, latest) has 1.1 and aspcud 1.9
* vivid (15.04, unreleased) has OPAM 1.2, so it's ok. Recommends aspcud, too

Note that there should be no conflict that I know of between OPAM 1.1 and aspcud 1.9 -- it's just that newer OPAM will benefit from the more advanced criteria offered. Where we have been hitting problems on Debian was by compiling with a different version of *Dose* [1] (which has a much less standardised interface).

There is still a known issue, though, the missing dependency on m4 that will bite you as soon as you try to install ocamlfind [2] and which is very badly reported with
===== ERROR while installing ocamlfind.1.5.5 =====
Internal error:
  "ocamlfind": command not found.

so it would still be nice if they could backport (so that there is a better error) or recommend m4.


[1] https://github.com/ocaml/opam/issues/1683
[2] https://github.com/ocaml/opam/issues/1658

- Anil Madhavapeddy, 09/12/2014 11:16 -
> It looks like the latest Ubuntu has a completely broken OPAM out of the box since it ships with OPAM 1.1.1 and Aspcud 1.9 (which requires OPAM 1.2 due to a changed solver interface).
> This leads to issues such as this: https://github.com/mirage/mirage-skeleton/issues/59
> Does anyone know how to get in touch with Ubuntu folk to request a backport of OPAM 1.2 to Ubuntu 14.10? 
> -anil
> _______________________________________________
> opam-devel mailing list
> opam-devel at lists.ocaml.org
> http://lists.ocaml.org/listinfo/opam-devel

More information about the opam-devel mailing list