[opam-devel] more depopts fun: joolog/lwt/react

Anil Madhavapeddy anil at recoil.org
Sat May 3 11:40:25 BST 2014

Here's an interesting failure:
- joolog.0.4 depends on react <1.0 and Lwt.react.
- lwt-2.4.5 has a depopt on react >= 1.0, and anything less will result in Lwt.react not getting compiledin.

Installing joolog causes react.0.9.4 and lwt.2.4.5 to get selected, which in turn causes lwt.react to not be installed and joolog.0.4 to error out.

A better selection would be for joolog's react conflict to select lwt.2.4.4 (which works with react<1.00).

For now I'm working around it via a joolog dependency on <lwt.2.4.5, but I thought I'd highlight this case for the ongoing depopt design work in OPAM 1.2.


More information about the opam-devel mailing list