[opam-devel] more depopts fun: joolog/lwt/react

Louis Gesbert louis.gesbert at ocamlpro.com
Mon May 5 11:46:16 BST 2014

Le samedi 3 mai 2014, 11:40:25 Anil Madhavapeddy a écrit :
> Here's an interesting failure:
> - joolog.0.4 depends on react <1.0 and Lwt.react.
> - lwt-2.4.5 has a depopt on react >= 1.0, and anything less will result in Lwt.react not getting compiledin.
> Installing joolog causes react.0.9.4 and lwt.2.4.5 to get selected, which in turn causes lwt.react to not be installed and joolog.0.4 to error out.
> A better selection would be for joolog's react conflict to select lwt.2.4.4 (which works with react<1.00).

This is a good example of the limitations of the current handling of version constraints in depopts !
The rewrite [1] would have lwt.2.4.5 conflict explicitely with react < 1, which would prevent it from being installed at the same time as joolog.

[1] https://github.com/ocaml/opam-repository/pull/1923/files#diff-44

> For now I'm working around it via a joolog dependency on <lwt.2.4.5, but I thought I'd highlight this case for the ongoing depopt design work in OPAM 1.2.
> -anil
> _______________________________________________
> opam-devel mailing list
> opam-devel at lists.ocaml.org
> http://lists.ocaml.org/listinfo/opam-devel

More information about the opam-devel mailing list