[opam-devel] [Caml-list] OPAM: retiring 3.12.1 testing?
louis.gesbert at ocamlpro.com
Tue Feb 17 00:36:17 GMT 2015
Thanks a lot for the detailed overview. I was indeed thinking it wouldn't be worth keeping both 4.02.0 and 4.02.1, but didn't know, for example, about 4.00.1. The first consequence of dropping e.g. support for 3.12.1 would probably be that incompatible packages are either not fixed, or not declared incompatible, which would lead to an error during compilation whenever OPAM tried to install them, instead of a clear message or a solution around that package/version if it exists.
Currently, according to the metadata, 561 of the 837 OPAM packages (67%) can be installed on 3.12.1, around 30 of which not at their latest version. The others either are not compatible or depend on an incompatible package.
OPAM itself (as opposed to the repo) will obviously keep compiling on 3.12.1 for the moment (the tests regularly help pick up an incompatible String.init or likewise)
Louis Gesbert -- OCamlPro
> - Adrien Nader, 16/02/2015 19:52 -
> On Mon, Feb 16, 2015, Anil Madhavapeddy wrote:
> > Dear OCaml list,
> > We are currently testing the following compiler versions on every pull request to OPAM;
> > - OCaml 3.12.1
> > - OCaml 4.00.1
> > - OCaml 4.01.0
> > - OCaml 4.02.0
> > We will shortly have to test 4.02.1, and would also like to test trunk snapshots of the
> > compiler as an "allowed failure".
> > Running 6 compiler revisions per package puts quite a bit of stress on our Travis CI
> > resources, and so it's probably time to retire OCaml 3.12.1 from the testing matrix.
> > Before we do this, I'd like to get a sense for how many people still care about ensuring
> > that their packages work well on the 3.12.1 series, or if there are still distributions
> > for which this support matters. If there is still sufficient interest, we can continue
> > to support 3.12.1 for some time.
> For yypkg/win-builds I've done a quick survey of what's in Linux
> distributions. I was mainly interested in moving past 3.12.1
> compatibility for my own code but found it undoable before the end of
> this year or maybe early next year.
> Ubuntu 12.04 has 3.12.1 and is still supported and widespread. 14.04 has
> 4.01.0 but isn't very old. Debian has a similar combination for its
> versions. I think 4.02.0 wasn't picked by linux distributions with
> long-term support (including RH if I'm not mistaken).
> 3.12.1 is really widespread and I think it has to be kept for a fairly
> long time. 4.00.0 is basically never used. 4.01.0 is widespread and will
> be widespread for some time. 4.02.0 is nowhere to be seen. I believe
> 4.02.0/1 and maybe 4.02.2 won't be picked up either (unless 4.03.0 takes
> close to two years to be released).
> I'd say: keep 3.12.1, 4.01.0, 4.02.whatever-is-the-most-recent (because
> that's what ocamlers use) and trunk. Dump the others (i.e. 4.00.1,
More information about the opam-devel