[opam-devel] OPAM on a Raspberry Pi 2

Dario Teixeira darioteixeira at yahoo.com
Tue Mar 31 13:43:14 BST 2015


I'm trying to use OPAM 1.2.1 on a Raspberry Pi 2 running Raspbian.
At first glance everything seems fine.  However, I'm running into
problems when attempting to install some packages with complex
dependencies.  OPAM complains that it cannot install package A
because it requires package B, instead of trying to install B
and its dependencies automatically.  I suspect the solver is
timing out prematurely given the lowly specs of the Pi 2.
(I have a similar setup in a more powerful ARM SBC, and
everything works fine).

I've tried installing aspcud, but OPAM complains that the
external solver produces bad output.  I've also tried setting
OPAMSOLVERTIMEOUT to a high value, but it does not seem to
make a difference.

In some cases I've managed to get around these errors by
manually following the dependency graph and installing
packages starting at the leaves first and then climbing up.
This sort of defeats the purpose of using OPAM, though.

Anyway, is anyone else experiencing similar problems?  And
if so, any suggestions on getting around them?

Thanks in advance!
Best regards,
Dario Teixeira

More information about the opam-devel mailing list