[opam-devel] opam getting compiler version wrong

Ashish Agarwal agarwal1975 at gmail.com
Wed Dec 7 15:04:52 GMT 2016

I'm getting this:

$ opam install ppx_sexp_conv.114.10+84
[ERROR] ppx_sexp_conv.114.10+84 has unmet availability conditions:
ocaml-version >= "4.03.0"

So opam thinks my ocaml version is < 4.03.0, but I'm in a 4.03.0 switch.
I've certainly run "eval `opam config env`". I created a new switch with
4.03.0 to try it from scratch, but get the same issue.

Sanity checks:

$ ocaml -version
The OCaml toplevel, version 4.03.0

$ opam info ocaml | grep all-installed-versions
all-installed-versions 4.03.0 [4.03.0]  4.04.0 [4.04.0]

Incidentally, I'm confused about the output of `opam info ocaml`. I have 6
switches on this computer. How come only 2 are listed above?

$ opam --version
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ocaml.org/pipermail/opam-devel/attachments/20161207/04e7f553/attachment.html>

More information about the opam-devel mailing list