[ocaml-platform] opam-in-a-box

Robert Muller robert.muller2 at gmail.com
Thu Jan 8 10:52:52 GMT 2015

Ah, thank you. I'm new to this, but I'm under the impression that this
package name isn't correct. I had already tried:

sudo apt-get install libgnomecanvas2.0-dev

but OPAM reported that there was no such package. So I tried a few other
things, I think I installed:

sudo apt-get install libgonecanvas2-0

which seemed to work, and I mistakenly assumed would get the -dev package
as well. So I just now did

sudo apt-get install libgnomecanvas2-dev

NB: there is no ".0". This worked and Kenichi's Universe package is now
working fine on ubuntu.

Many thanks,
Bob Muller

On Thu, Jan 8, 2015 at 5:36 AM, Jeremy Yallop <yallop at gmail.com> wrote:

> On 8 January 2015 at 03:41, Robert Muller <robert.muller2 at gmail.com>
> wrote:
> > [ERROR] The compilation of conf-gnomecanvas.2 failed.
> The purpose of the conf-gnomecanvas package is to check that you have
> the appropriate system package for the libgnomecanvas library
> installed.  The description (which you can see with 'opam show
> conf-gnomecanvas') says:
>     This package can only install if libgnomecanvs2.0-dev is installed
> on the system.
> OPAM can also list the system package dependencies for you:
>    opam list conf-gnomecanvas --external
> So the following should help:
>     sudo apt-get install libgnomecanvas2.0-dev
> You might also be interested to know that the Universe Library now has
> OPAM support, so the following will install the OPAM dependencies and
> build and install the package:
>     opam pin add universe https://github.com/kenichi-asai/Universe
> Finally:it's best not to run OPAM using 'sudo'.  It's designed to run
> with normal user permissions and install files under your home
> directory.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ocaml.org/pipermail/platform/attachments/20150108/a650cd0f/attachment.html>

More information about the Platform mailing list