[ocaml-platform] opam update problem

Shon Feder shon.feder at gmail.com
Fri Oct 23 03:16:59 BST 2015

In case this will save some future people some future time:

I seemed to be experiencing a similar, bot not identical problem. 
I had the following setup:

  - OS X: v 10.11
  - OPAM: v 1.2.2_1
  - wget: v 1.13.4

and when I attempted to update opam it looked like this:

$ opam update

=-=- Updating package repositories =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=  🐫
[ERROR] Could not update repository default

By following this thread, I got as far as running `opam update -vv`, 
but I did not receive the same illuminating information as OP. Instead 
I had this result:

[default: http] Command started
+ wget "--content-disposition" "--no-check-certificate" "-t" "3"
- Usage: wget [OPTION]... [URL]...
- Try `wget --help' for more options.
[ERROR] Could not update repository default 

tbh, I don't know what it was trying to indicate, but I guessed it was 
an issue with wget. I checked http://ftp.gnu.org/gnu/wget/ and learned
wget 1.13.4 was no longer current. So I ran

$ brew update
$ brew install wget

Which upgraded me to the latest version (1.16.3, at the time I write this).
Afterwards, `opam update` worked without a problem.

Thanks to all you problem solvers in this thread who helped me get this far. :)

More information about the Platform mailing list